USB-C connection through USB hub not working

i am using a microsoft surface pro which has a USB-C port. I connect this USB-C with a USB-C hub which allows me to connect to different devices using HDMI, USB and USB-C. when I connect MokuGo to the USB-C connector on the USB-C hub, MokuGo did not show up. No matter how I do power cycle or replugging the USB-C cable. I just don’t hear the connection sound usually associated with device detect on the laptop. However, if I plug to the USB-C port directly without the hub, MokuGo will be detected and show up nicely. This is very inconvenient as I need to use my external monitor when doing the demo projecting with HDMI. Is also very inconvenient that I don’t have split screen when I do zoom demo which I can share screen and work on something at the same time. any work around will be appreciated.

Hi @SpringTechDavid

thanks for your message on the forum. There are few things to check

  • update to the latest app and Firmware : Moku:Go software update 2 June 2021; version 0.9.4

  • ensure that the Moku:Go is connected to power via its magnetic power socket and that it shows a GREEN status light

  • you may find that it is necessary to have a powered USB-C hub

Please let us all know how you get on with these suggestions,


Hi Paul,

Thanks for the advice. I had done one and two already before that. The last thing I suspect is the current from the hub is less than ideal.

BTW, the USB-C direct connection seems to be able to power MokuGo. I tried it without using the power adaptor and it works. Will there be any performance difference if I use USB-C power compared to the DC adaptor?



Hi David,

yes, I think the USB-C hub needs to be powered (from external USB-C PD adaptor) to be reliable.

There is another connection method that works : USB-type A to USB-C cable. And this cable works for unpowered USB-C hubs that provide a USB A type port.

The USB-C connection can supply power to Moku:Go’s that are configured with firmware 543 from the factory. We have noticed that some of the early evaluator units do also work once upgraded to firmware 543. For all Moku:Gos, the PPSUs (programmable power supplies) can only be used when the magnetic power is connected.


Thanks for your reply, Paul. I will go research the cable. Best, David

I have a similar issue M1 unit using a Dell laptop, software is 0.9.4, powered by magnetic power socket (green light). In using either a USB-C to USB-C cable from the laptop or USB-A to USB-C I “hear the USB connection made” but Moku:Go software does not find the device. I also tried to connect via wifi as an access point. I see the device but in following the Quick Start instructions it lists a “default password is printed alongside the serial number, labeled as PSK”, but I find no such information just a number with my model number (at the end) and then a 12 digit hex type address separated by colons i.e. FF:EE:…

Hello Gerald, thanks for using the LI forum!

Re WiFi password - For the sample program, the default WiFi AP password is mokuadmin. If this doesn’t work, please send me a private message with your serial number and I can help reset it.

Re USBC issues - With the Moku:Go powered on and the USBC plugged into your Dell check your Device Manager list under Network Adapters and be sure Moku:Go shows up like in the screenshot below. If not, please reinstall the Moku desktop here. When you reinstall you may need to install as admin or check firewall settings to make sure the certificates download correctly.


If you are still having issues with USBC, try checking the steps in this post here.

Sam thanks for the notes…I’m now connected which is great…I used the default wifi password and didn’t really see a difference but I went to the Network Adapters in Device Manager and found MokuGo, I then tried the settings:gear in the Moku:Go app and connected manually using the “IPv4 DNS servers:” address and got connected and have tested the scope, hope to report more soon

1 Like