Power Supply Bug

I found out an embarrassing bug with the power supply display during a demo session yesterday.

I connect the moku:go to my surface laptop without an external monitor. I went into the oscilloscope app and then try to turn on the power supply. the power supply screen did not appear at all.

I had been trying to duplicate this bug the whole morning. by power recycle my PC, mokugo and the USB connection cable step by step. I even uninstall and install the mokugo Windows software. the same bug keeps appearing. this bug is also consistent when I use the spectrum analyser too.

i never encounter this problem before because I usually use an external monitor as I can work on a bigger screen which is good for demo. so with an external monitor, the power supply screen will definitely be displayed.

I suspect the bug to be when the power supply screen is been activated. it jumped out to another display area and not within the oscilloscope screen. the “other area” happens to be on the external screen which is why I cannot see it. so without an external monitor, the power supply screen cannot be seen at all.

I suggest that the power supply screen remains in the same oscilloscope screen or what ever instrument that was been use at the time to avoid this problem when there is no external monitor attached

Thank you for reporting this Bug to us in the forum David!

I understand the issue with the Power Supply pop-up window not being displayed correctly when using a single screen setup (your Surface Laptop) but does display when you are using multiple monitors. I have passed this along to our client team.

If possible, do you remember what actions you took while using the Moku:Go desktop app before you disconnected the external monitor? For example, did you have the Power Supply window sitting in the external monitor’s screen and then changed instruments without closing the Power Supply window? Any additional information would be extremely helpful! Thank you.

thanks for the reply Sam. Before i notice this bug, I was using my external monitor to make some final tests before I left my office. i did not shut down my computer, it was on sleep mode when I left my office before making it to the next meeting for the demo. after I notice the bug during the meeting, I start doing debug and found this behavior when I try to replicate it in the office and carry out the test from a fresh slate to confirm my hunch of the bug.

1 Like


I cannot enable the power supply from within any instrument. When I click on Power Supply, the little window does not show up. It seems like this problem is similar to the issue reported here:

However, even after I connect the Moku:Go to multiple monitors, the power supply does not show up. I have tried disconnecting and reconnecting the Moku several times, but I still cannot access the power supply.

Is there a way to fix this? Will a factory reset fix it?

Hello Farah,

Thank you for posting to the LI forum! I am sorry to hear that you are also experiencing this issue. We are aware of this bug and are working on a fix for it, but until then there are a few things you can try that may help.

This bug generally only occurs when using more than one monitor with the Moku:Go desktop app and the power supply window is dragged into a different monitor screen than where the app is and then the application is closed or the Moku:Go is powered off while the power supply window is still in the other monitor screen area. Some things to try below…

  1. Uninstall and reinstall the desktop app. Be sure to also delete the Liquid Instruments folder as well located in the Program Files section of your C: drive.
  2. Factory reset the Moku:Go (this is done by the reset button on the bottom and must be done when the front LED is green)
  3. Using the same multi-monitor setup used when (or before) the bug occurred and having the app open with the power supply window “opened”, change the ‘Multiple Displays’ options. Any of them may work for you, but changing to ‘Duplicate displays’ has worked for me.
  4. If (3) doesn’t work, try changing which monitor is your main display monitor under the same conditions described in (3).
  5. Try connecting to a different monitor you have not used before. The Windows OS tends to remember what settings you have for applications on a specific monitor, so trying a new monitor will likely reset the window positions.

Please let me know if any of the above works for you. This is a duplicate issue post so I will be merging yours and David’s post.

Hi Sam,

Thank you for replying to my post. Based on your suggestions, I was able to fix the problem by doing the following: I connected to the same multi-monitor setup when the bug occurred. I opened the power supply window from the oscilloscope app, and it appeared in the same spot on my second display. I moved it over to where the main Moku app was on the first display. Then, when I disconnected the second display, both the Moku app and the power supply moved over to my first display.

This bug occurred on my home setup where the external monitor and my laptop are aligned one below the other in the Display Settings. My office and the classroom setup has the monitors aligned next to each other. I suspect the problem could be that the power supply did open, but it was off screen because there was no monitor “underneath” the main display. So, it seems like that for the power supply window to show up, not only the second screen needs to be connected, but it needs to be in the same alignment with the main screen when it was last used.

It works now, so I believe the take home lesson (like David mentioned at the end of the original post) is to keep the power supply window with the main Moku app on the same screen before shutting down or disconnecting the Moku:Go.

1 Like