Moku:Go USB-C connection not showing up in Windows App

Continuing the discussion from Moku:Go software update 11 May 2021; version 0.9.3:

I am moving this issue to a new topic so other evaluators can more easily find it. The issue is that when connecting the Moku:Go to a Windows PC through the included USB-C to USB-C cable, the Moku:Go is not showing up as a device in the Windows App.

@mlamparter in your Device Manager window check under “Network adapters” and see if there is a driver/device titled “MokuGo #12” (note this is not the serial number associated with your Moku:Go)

image

If not, then please follow these steps…

  1. In the Device Manager menu bar select Action → Legacy Hardware
  2. In the “Add Hardware Wizard” popup, click Next then select the (Advanced) option and then Next again
  3. Click “Show All Devices” at the top of the list, then click Next
  4. Scroll down the Manufacturer list until you find Liquid Instruments and select it
  5. Select the “MokuGo” Certificate and follow the on-screen instructions to update/install the drivers and certificate
  6. Once the certificate/drivers are installed, the Add Hardware Wizard may say “This device cannot start. (Code 10)” which is normal and you can go ahead and click Finish.

Please let me know if this does not fix your issue and I will be happy to help you further!

1 Like

If you get to step (4) and cannot locate Liquid Instruments as a Manufacturer, then please uninstall and reinstall the Windows App. It is likely the driver certificates did not install correctly.

Alternatively, your device may show up under “Other devices” and is listed as “MokuGo”

image

Right-click “MokuGo” and select the update drivers option and have the Update Drivers Wizard automatically search for drivers on your PC. If it cannot find any drivers, then uninstall and reinstall the Windows App.

Sorry for such a delayed response. I was out of my office for several days. I followed your instructions. My Moku:Go seems to show up just fine in Device Manager under Network Adapters as “MokuGo.” Despite this I still followed your original set of instructions to add a legacy device. After completing those steps I had a second device show up directly below the first and it was labelled “MokuGo #2”. Nothing changed in the software so I removed this second device.

I next took your suggestion of uninstalling the Windows App and then reinstalled the v0.9.3 Windows app again. Still no change. The LED indicator on my device is solid green and Windows sees the device and seems to recognize it. But the software never locates it. What should I try next?

My department chair is having similar difficulties with his own Moku:Go. It worked fine on his personal computer at home but here on campus his device will not work with a lab computer.

Thanks to the Liquid Instrument folks for working with me directly to address this problem! I spoke with my IT department here and discovered that the USB-C connection requires the use of IPv6 to function properly. Our IT department has IPv6 disabled by default on all university-owned machines due to some issues they have experienced using this protocol. When I manually enabled IPv6 and rebooted my computer that resolved my issue. I can now connect to my Moku:Go via USB-C when using the Moku:Go software. Thanks, all!

3 Likes