Cannot connect to Moku:Go on a managed PC with IT restictions

Cannot connect to Moku:Go via USB. I can connect via WiFi, but only by supplying the IP address manually, the Moku software and mokucli does not detect the device at all.

The computer is managed and had IPv6 disabled, and the local user does not have admin privileges. I’ve asked IT to enable IPv6, they said they did. MokuGo appears as a network connection, and Properties show both IPv4 and IPv6. The interface gets a link-local address ( If I disable IPv4 and leave only IPv6 nothing happens. The Moku app does not see the device at all.

If I connect to the wifi AP the interface gets a valid IPv4 address, but the Moku app does not see the device anyway and “moku list” returns empty. I can find the IP address of the Moku:Go via arp -a, and if I specify the address manually in the Moku app it connects and I can use it from the app. I cannot use it from Python, but that’s perhaps a different subject.

This is on Windows 10 Enterprise 22H2. Moku v3.2.0.

Btw, I’m attempting this from a device that uses IPv4 to control several other devices, ipconfig returns 10 interfaces. And the first time I did connect via wifi Moku app requested the firmware to be updated and I did so.

Hey @lukask

I can’t reproduce this issue on my end, so I spoke to the team that writes the App and API discovery protocol and there have been other instances where the IT management blocks our Moku discovery protocols. Unfortunately, you may be affected by this too.

There is nothing we can do on our end to unblock this as we have no control over the IT service, so I think the best way forward is to discuss with your IT team to understand how they are limiting your IPV4/6 and WiFi discovery to be able to use the App and “mokulist” discovery through USB and WiFi. You’ll continue to be able to use “manual connection” in the App and the API connection (e.g. Oscilloscope(IP, force_connect=True) until your IT privileges are fixed.

I hope this helps!

Indeed this might be due to IT restrictions as there are many on our managed PCs. It would be good to know what needs to be enabled for Moku:Go to work on managed networks. I know that “IPv6” needs to be enabled, and it is, as reported by gpresult /r -scope:computer. Perhaps something else needs to be enabled too?

The root of the problem is that the Moku Eth interface via USB-C does not get an IPv6 address. Not sure if this is related to the the Moku app or mokulist and their discovery process.

We worked on this issue with IT, and eventually the Moku:Go did get an IPv6 address over USB-C on one machine. I’m not sure what helped, perhaps running the Moku app with local admin privileges. Maybe this had to do with driver installation, although the Moku app installation was carried out with local admin privileges. However, I wasn’t able to replicate this fix on another machine where the Moku:Go also does not connect via USB-C, so not sure if I learned anything here.

I can use Moku:Go over wifi in a pinch, but this seems suboptimal in terms of reliability and perhaps data transfer rate. It would be good to understand what is needed to run Moku:Go on managed networks with IPv6 restrictions, other than enabling IPv6 support.

Thanks for the help @indira!