Issues with Moku GO using in Labview (IP address)

I have met something with using Moku GO with Labview. I have entered IP address, which I have used same address well in Python. However, in Labview, it report Error message code 54. I am not sure how to solve this problem.
截屏2024-04-24 12.27.21

Hi @Sushiki

Thank you for posting. The Moku connection failure is likely due to the fact that LabVIEW doesn’t support an IPv6 address. May I ask how you connected Moku to a PC, i.e. WiFi / Ethernet / USB? If via WiFi or Ethernet, you can find the IPv4 address under the corresponding tab of Device settings, as shown in the screenshot. In the case of USB, as USB requires the use of IPv6 to function properly, you would need to set up a proxy port to convert the IPv6 address into a IPv4 format. The instructions can be found via this link: https://knowledge.liquidinstruments.com/moku-labview-api-support-over-usb.

Please kindly let me know how this goes. Thank you!

Best regards,
Le

Dear Wang,
Thank you for your assistance. What I use is USB, and I have convert IPv6 to IPv4 according to the instructions. However, the labview also cannot work, and it report Error message 42. Here I show the screenshot. If you could help me solve this problem, it would be really helpful. Thank you for your help.

Dear Sushiki,

Thank you for sharing the feedback. I tried the Moku:Go Oscilloscope LabVIEW example on my side with USB connection, and I couldn’t reproduce this error message. Could I trouble you to check on a few things?

(1) Did you modify any sub-VIs in this example, especially the ‘Get_Data.vi’? If so, could you please share the updated .vi file so that I can try running it on my side?

(2) Could you quickly try other examples and see if they report the same error?

Thank you very much!