Correct IP address for Matlab

I am just getting started with the Matlab API. The example code gives a IPv4 IP address, but the MokuGo returns an IPv6 IP address which creates an error in the Matlab example script. Is there any documentation on how to address this?

Hi there Alan, thanks for posting to the LI forum!

Right now, there are two different MATLAB toolboxes that are specific to Moku:Lab and Moku:Go. To use the Moku:Go MATLAB toolbox, go through the Add-On Manager and just search ‘Moku’ and it will be the first search result and is version 1.1.0.

The Moku:Lab toolbox is downloaded from our website and is not compatible with Moku:Go at this time. Please be sure to uninstall the Moku:Lab toolbox BEFORE installing the Moku:Go toolbox as this can cause issues when trying to connect.

You should still use the IPv4 address to connect to your Moku:Go. You can find this in the client app in the Device Select screen when connected to your Moku:Go. Right-click on the device and click the “Copy IP Address” option.

Let me know if this works for you and if you have any other questions/issues!

I’m having difficult connecting to my MokuGo in matlab, I’ve uninstalled the moku addins and reinstalled only the moku version 1.1.0 add-in through matlab. I copy the ip address through the application on windows and paste it into the matlab example and I get errors from the ip connection.

I have pinged my MokuGo in the command prompt and the ethernet connection is fine.

I appreciate your help!


Hey Joe, thanks for posting this issue to our forum!

Could you please copy the error code here or insert a screenshot?

It is possible the toolbox path did not install correctly, check that the mokugo toolbox path is in the “Set Path” window (see screenshot below).

I checked the matlab set path and the mokugo folder is added properly. I tried running one of the example scripts for the arbitrary waveform generator. Attached is a screen shot of the result.

Thanks for the help

This is the matlab script

Hey Joe,

This is the error thrown when MATLAB cannot connect to the Moku:Go with the given IP address. You said you are connecting to the Go over ethernet, are you on the same subnet as the Go? If you are and it is still not working, try the ‘Manual Connect’ method detailed below.

In the Moku Desktop App, click the settings gear in the bottom-right of the screen, select Connect, then Manual connection…


Then just enter the IP address of the Moku:Go which can be copied from the device select screen.


Please let me know if you are still not able to connect using ethernet this way. If you are able, also try connecting to your Moku:Go using the WiFi hotspot and see if MATLAB is able to connect through this method.

1 Like