New Firmware Update causes Crashes

Moku model:Moku:Go
Operating system:MacOS/Windows
Firmware version 587

Bug or support request description:


we have been using the moku:go for several months and uploading our own custom code from the Cloud compile feature. It has worked well. However, today we updated the firmware for the moku app and now our moku:go platforms crash any time we try to upload a bitstream. We have tried using the User interface as well as the python API, both cause the same issue. The issue is also happening on both of our moku:go platforms. It has the same issue on windows as well as MacOS. Is there any reason why the new update might be causing this issue? The crash seems to happen after uploading the bitstream to cloud compile in multi instrument mode and pressing “apply changes”. The moku:go will load for a few seconds, before crashing not recovering. It needs to be restarted everytime this happens as it is unusable afterwards (will not show up when connecting to it via wifi or USBC).

Hi Ryan,

great to hear you are making good use of Moku Cloud Compile (MCC).

The MCC bitstreams must be compiled with the same firmware version as your Moku. So you will need to create a new ‘device’ within your MCC account for firmware 587; then recompile your custom code.

I hope that makes sense - let me know if you need further help.

And thanks for asking this question on the forum, there might be other MCC users with the same issue.


Perfect, thank you. That fixed it