Issues updating Moku:Lab firmware

Moku model: Moku:Lab
Operating system: Windows
Software version: 3.2.0, firmware 516

I am attempting to update a Moku:Lab to firmware version 591. I tried to do this through the Moku windows software, though after waiting a while for the progress bar, it throws an error about the Moku disconnecting. I have also tried via the iPad app which gives the same error.
Any help is appreciated, thanks.

Hi mapelleg,

Have you tried to power cycle your Moku:Lab and then update the firmware to version 591? Sometimes the bitstreams cache can become full and while upgrading it does not have enough space to store or unpack the firmware file. Power cycling will clear this and should allow you to upgrade your firmware successfully.

Please let us know if you still have issues with this.

I have tried power cycling before updating the firmware and the error message still persists.

Hi @mapelleg,
I was hoping to get a little more info about your Moku:Lab for a better picture. Could you please send through:

  1. The serial number of your Moku:Lab
  2. If you’ve tried to upgrade it since you bought it or if you received it with 516 firmware installed
  3. If you have upgraded it, do you remember when or how you upgraded it to firmware 516?

If you could also double-check the firmware that would be super helpful, right click on the device and screenshot like below:


Hi Nadia,
The serial number of the Moku is 000715. I received the Moku with firmware version 516, so I don’t know how or when it was upgraded to firmware 516. Below is a screenshot showing the firmware version:

Hi @mapelleg,

Thanks for providing that information with us. Please bear with us as we try to reproduce this issue on our end and find a solution for you. It is looking like quite a unique issue, would you mind contacting customer support at so that we can contact you directly there.


Hi Indira,
I have sent an email.