No readings detected with oscilloscope

I have a Moku:Go and am running the Windows 11 with the latest firmware & software (569? & 2.4.2 build 16204). I am not sure what has happened but I am no longer getting any readings from the oscilloscope instrument.
Using a voltmeter I can confirm the circuit I am measuring has a voltage of approximately 1.8v however the oscilloscope only shows a solid zero volts. I’ve tried with measuring using both channels and with different probes however it doesn’t seem to make a difference. I’ve also reset the Moku:Go (using the reset button) and uninstalled / re-installed the software.

Is there anything else I can try to resolve or troubleshoot this?

Hi KM,

sorry to hear you are having difficulties with your Moku:Go. You have certainly done some good trouble shooting, a couple of additional ideas to check

  • since this is a DC 1.8v signal, please make sure the oscilloscope is set to DC coupling, not AC coupling
  • can you confirm if both input channels on the Moku:Go behave in the same way?
  • finally, perhaps check by connecting Moku:Go output 1 to Moku:Go input 1, then setting the oscilloscope function generator to 1 KHz 1Vpp signal; does the oscilloscope show this test signal ? Double click to auto-scale.

For the oscilloscope function generator see page 17 of the Moku:Go oscilloscope manual :



thanks for the quick reply Paul.

A few notes;

  • i’ve definitely set the coupling to DC
  • both channels are behaving this way.
  • I did what you suggested, set output 1 to output a 1khz 1Vpp sine signal and then connected it to input one but i did not see any measurements.
  • If i set channel A to output 1 then i could see the sine wave signal

For interest sake I also tried setting the output waveform to DC and 1V and wasn’t able to observe it on my voltmeter. I was able to observe output from the power supplies on the rear of the Moku:Go though.

Can you confirm what the relationship is between channel A & B and input 1 and 2? I had assumed that input 1 is channel A and input 2 is channel B

The relationship between the channels is as you described typically. It is possible to choose the channel source for both Channel A and Channel B as I’m sure you’ve seen, but by default Channel A = Input 1 and Channel B = Input 2.


Since you’ve gone through all of the common issues we find with users reporting this issue, and did a factory reset, I think it would be best for us to schedule a quick troubleshooting call so someone from the apps team can go through a few things live and determine if we need to send a replacement. Would you mind filling out this support form so we can get you in our ticket system and get this fixed for you asap?