No Moku Cloud Compile in Multi-Instrument Mode on Moku:Go

Moku model: Moku:Go (M2)
Operating system: Mac
Software version: 2.5.1
Firmware version: 574

Bug or support request description:

I just set up a Moku:Go and want to test out the Moku Cloud Compile instrument on it. The documentation specifies that MCC is available for the Moku:Go, however it does not show up as an instrument option when selecting instruments in Multi Instrument Mode

Over WiFi, I navigate to my Moku:Go’s IP address and went to the Registers tab, and it only shows a single slot (I believe the Moku:Go should have 2), which I can’t deploy. Is there a step that I need to take in order to access MCC?

It looks like you are missing MCC in your MiM configuration. This happens because the instrument license on your Moku:Go likely hasn’t been updated locally. Please refer to this article on how to update the instrument license.

If you update the license and you still do not have MCC (or are missing instruments in future releases), then please send me a private message with your serial number so that I can update the license on our server.

Thanks Sam - I tried this previously with the Auto serial number, and just tried now with the specific serial number of my Moku:Go, but it unfortunately doesn’t seem to add the MCC instrument (I also tried power cycling after updating the device).

I’ve just noticed that I generally have a problem with a MiM, where I cannot apply any of the instruments as well - here’s a screenshot of the error.

I’ll message you the serial number now, thanks!

Thanks @Sam.Speece for updating the license! I can now see Moku Cloud Compile in Multi-Instrument mode, so that seems to have solved it.

I did notice that I get the same “Failed to Deploy” error in my previous post in MiM if I have an empty slot when I try to apply the settings. This seems like a corner case for a bug, since the use case for MiM is of course to use multiple instruments, not zero or one. But, thought I’d report that nonetheless.


This should not be the case with deploying a single instrument in Multi-instrument Mode. You can see in the screenshot below that I have deployed an oscilloscope in slot 1 but have nothing in slot 2.

If you are getting an error when trying to deploy MCC into MiM, then it likely means that you have not yet uploaded the MCC bitstream to your Moku:Go yet. We have steps for how to do this here. Could you provide a screenshot of the error and the setup you are trying to deploy that gives you the ‘Failed to Deploy’ error?

2 posts were split to a new topic: Failed to Deploy. An internal error occurred (Error code 5)