Failed to Deploy. An internal error occurred (Error code 5)

Thanks - I’m getting this error with a single instrument, regardless of if I’m using MCC. Using your exact setup with the oscilloscope and trying to apply to the Moku:Go, this is the error that I get:

Could you try a few different configurations and tell me if this issue persists? For example, FRA in slot 2, PID in slot 1 with no inputs or outputs, etc. It would also be helpful if you could check your Moku’s instrument license permissions according to the post below.

I am not able to recreate this issue on my end and have turned it over to our client team to look into more. I will respond here when I have new information for you. For now, you can of course use the standalone instruments instead of deploying a single instrument in MiM, or deploy a second instrument to avoid this error.

Error code 5 generally means there is an issue with your license permissions. It is a good idea to check that you have downloaded your latest instrument license from our servers by referring to this knowledge base post.

Alternatively, you can check which instruments you have access to and when the last time your instrument license was updated, as well as fetch the latest instrument license for your Moku. To do this, you must be connected to your Moku via WiFi or Ethernet. Copy the IP address by right-clicking on your Moku in the ‘Select your device’ screen, hover ‘device info’, and click 'Copy IP address (on iPad, tap and hold on the Moku device card to display the IP address). Paste the IP address into any browser and at the top of your screen you should see your Moku’s instrument license permissions like below.

Each instrument will have their own license. If you just see “All instruments” then you have access to all available instruments for that Moku. “Custom” means you have access to Moku Cloud Compile. “Multi-instrument” means you have access to Multi-instrument Mode.

By clicking the refresh icon in the top right, you can update your Moku’s instrument license and it will tell you the last time it was updated as well.

It is also possible to upload an instrument license via a local file. This is for users that have issues downloading the license due to certain firewall settings on their network. To do this, please contact for your Moku’s instrument license file. Please provide your serial number when doing so.

Thanks! I tried a few different configurations, and whenever two instruments are loaded, there is no error, but only when there’s one being loaded in either slot. If I load two instruments, and clear the MiM and try to apply, I also receive the same error. Here’s some screenshots of doing that:


(3) (4)

For the license, I just checked via the IP, and I have the same ones set up, so there’s no clear answer there unfortunately:

Happy to try anything else!

Thank you for sending through this information, it was very helpful! Our dev team has pushed a fix to the license server. Please refresh you license again and try launching an single instrument in MiM, it should work for you now. Let me know if you run into any other issues!

Just updated the license, and it works now. Thanks!

is it in general intended to use only a part of the slots in multi-instrument mode?
With our Moku:Pro I also get the mentioned error message if not all slots are loaded with instruments.

Kind regards ,

Multi-instrument Mode is intended to be able to use any number of slots with any instruments, whether all slots are filled or only one slot has an instrument.

This fix won’t go into effect for everyone until the January release, if you would like this issue resolved right now could you please privately message me your Moku:Pro’s serial number?